What are the system requirements for the ReadCube desktop application?

To use ReadCube, you must be able to run Adobe AIR 2.6. The system requirements for ReadCube/AIR 2.6 are as follows:

Operating Systems
Mac OS X 10.7 or newer (Intel CPU-based Macs only)
Windows Vista with Service Pack 1
Windows 7
Windows 8
Windows 10

* We do not officially support beta/test OS versions. The app can be freely installed on betas but please note that there may be potential issues that we will not be able to help troubleshoot.

Hardware
Intel x86 or Atom CPU
Pentium III, Pentium 4 - 1GHz minimum, 2GHz or faster recommended
512MB RAM minimum, 1GB+ RAM recommended


Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.